Forge 1.17 Now Supported!

Wednesday, July 28, 2021

1.17 forge is now supported on all our systems. To run 1.17 Forge your server might need its startup settings changed, if this is the case, please contact support.

We're working on an automated system where it will detect the Forge version and then apply the correct startup settings. This isn't fully ready yet, as supporting the new forge was the top priority for us, and we wanted to get it out as soon as possible.

Enjoy what 1.17 Forge has to offer


« Back